Internet Outage Monday 28th March 2022 07:33:00


Update 7:33: We are investigating issues with the district internet connection. The problem affects all buildings.

Update 8:35: A fiber cable cut in the vicinity of Frederick Street in Millersville is the cause. Repair crews are onsite now. 

Update 8:45: Service has been restored. Happy Monday!